# Error in init file server data! File server disabled!

**URL:** <https://community.mobotix.com/t/error-in-init-file-server-data-file-server-disabled/9407>\
**Category:** Camera Software\
**Tags:** troubleshooting\
**Created:** [February 17, 2025, 7:34am UTC](https://community.mobotix.com/t/error-in-init-file-server-data-file-server-disabled/9407 "2025-02-17T07:34:54Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![msharara](https://avatars.discourse-cdn.com/v4/letter/m/8e8cbc/32.png) [@msharara](https://community.mobotix.com/u/msharara)\
**Post date:** [February 17, 2025, 7:34am UTC](https://community.mobotix.com/t/error-in-init-file-server-data-file-server-disabled/9407/1 "2025-02-17T07:34:54Z")

</div>

Hello,

We have an issue with my Mobotix model Mx-v71A-8DN050.

After I configure it, it gives me an error in the File Server / Flash Device:

- **Error in init file server data! File server disabled!**

Can you tell me what that means and how I can troubleshoot?

 ![image](https://canada1.discourse-cdn.com/flex030/uploads/mobotix/original/2X/a/a424eb5569d82a0f2b1d92701d2dbdeaed0d357d.png)

Also, I have tested the storage configuration, and it is working fine.

Please see the screenshot.

 ![image](https://canada1.discourse-cdn.com/flex030/uploads/mobotix/original/2X/b/becec866af2724c894f399029d19e1578d5e043f.png)

---

<div class="post-metadata">

**Author:** ![BOfH](https://avatars.discourse-cdn.com/v4/letter/b/f6c823/32.png) [@BOfH](https://community.mobotix.com/u/BOfH)\
**Post date:** [April 14, 2025, 8:20am UTC](https://community.mobotix.com/t/error-in-init-file-server-data-file-server-disabled/9407/2 "2025-04-14T08:20:44Z")

</div>

This is my first post in the community, so ..  
I had the same problem last week with some of identical configured M73/S74 cameras, but not with all of them. The log file log.txt on the server shows:

> 2025-04-11 18:18:21 mx10-32-27-200 **‘/.erdinfo’** not found  
> 2025-04-11 18:18:21 mx10-32-27-200 force scanning file system …  
> 2025-04-11 18:18:21 mx10-32-27-200 **Value too large for defined data type** get filesystem statistics in basepath!  
> 2025-04-11 18:18:21 mx10-32-27-200 init failed with initialize failed!

Test of the file server in the camera said, that “File Server is usable”. Nevertheless, test of the storage server from within the camera shows, that the camera could not get size/free GB data from the file server. So the file server disabled.

First I thought, it would be a camera problem, but instead, it shows to be a server problem.  
Our server is currently debian bookwarm with latest patches from Monday last week.

I managed to fix the problem with 2 tasks:

- debian releases a new kernel module at the end of the week (?!), where ZFS had to be compiled anew. (ZFS is our main storage system.)
- Hints from Mobotix during configuring of the server, tells us, that the NFS storage system had to be exported with **no\_root\_squash**. But for some reason, **no\_subtree\_check** has to be added too. Rem: Within the NFS directory, each camera creates his own folder, whith the events will be recorded in subfolder of these.  
I don’t know, if only one of the changes would have been sufficient, and I have to check the other comeras too.

---

<div class="post-metadata">

**Author:** ![BOfH](https://avatars.discourse-cdn.com/v4/letter/b/f6c823/32.png) [@BOfH](https://community.mobotix.com/u/BOfH)\
**Post date:** [October 1, 2025, 11:43am UTC](https://community.mobotix.com/t/error-in-init-file-server-data-file-server-disabled/9407/3 "2025-10-01T11:43:57Z")

</div>

Well, some hints/pitfalls for storing on an nfs server, I stumbled on. Since I write these lines some weeks after successfull testing my setup, there is no guarantee, that some hints are incorrect. Especially, because I use German Language during installation.

My Camera-Modell is Mobotix M73/S74, latest Software revision.

- The exported NFS file system should not exceed 4TB. It seems, that there are some limitations on the M73/S74.

- UID/GID: I used a special UID=1001/GID=1001 combination on the file server. Mobotix suggests to use UID=65534 and GID=0

- If you test the file server with the button Start Test in the admin menu Storing on External File Server, you get a popup-screen, showing severall test.

- If you activate the event-protokoll, the file log.txt will be stored using the UID/GID (at least, if S-Bit on the folder has been set)

- The camera tries to write in SystemMessages.log and WebServerMessages.log, if Camera-Logfiles have been set to true.These files will be written with UID=root! Same for the self-signed certificate cert.pem, if you access the web-frontend with HTTPS.

If you detect errors, more pitfalls, I’ll try to incorporate them in this post.

---

<div class="post-metadata">

**Author:** ![msharara](https://avatars.discourse-cdn.com/v4/letter/m/8e8cbc/32.png) [@msharara](https://community.mobotix.com/u/msharara)\
**Post date:** [October 1, 2025, 2:20pm UTC](https://community.mobotix.com/t/error-in-init-file-server-data-file-server-disabled/9407/4 "2025-10-01T14:20:48Z")

</div>

I resolved the issue by setting up a Linux server and configuring the camera to store data there. Before, I used to store the camera in my pure storage directly

---

<div class="post-metadata">

**Author:** ![BOfH](https://avatars.discourse-cdn.com/v4/letter/b/f6c823/32.png) [@BOfH](https://community.mobotix.com/u/BOfH)\
**Post date:** [October 2, 2025, 3:31pm UTC](https://community.mobotix.com/t/error-in-init-file-server-data-file-server-disabled/9407/5 "2025-10-02T15:31:57Z")

</div>

Well, I got the problem within debian/bookworm…
