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General information 

1 General information 

1.1 PDF format 

1.1.1 Supported viewer 
The PDF manual can be used with the following viewers: 

� Adobe Reader from version 6.0 
� Foxit Reader from version 5.0 

1.2 Info boxes 
ATTENTION 
This information box addresses all necessary configuration options and actions which will 

allow error-free operation. Also, this box will warn you if a certain configuration, option or 
entered value could lead to a malfunction of the application or a loss of data. 

NOTE 
This information box serves multiple purposes: It ranges from basic configuration tips to 

additional advice and comments on occasional settings and events. 

GOOD TO KNOW 
This information box provides background knowledge which helps to understand the basic 

principles behind different configurations and the application itself. 
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2. Overview  

2.1 Intercom solutions by Commend 
The Commend Intercom system is an open platform and in all respects provides full 
compatibility for third-party components. This enables us to create perfectly tailored turnkey 
solutions in cooperation with strong partners such as MOBOTIX HUB VMS Systems.  

Commend provides an interface to MOBOTIX HUB, which enables the communication from 
the Intercom system to the MOBOTIX HUB VMS by sending TCP strings. The basic idea behind 
the TCP interface is to provide all kinds of Intercom features to trigger generic events in the 
MOBOTIX HUB system.  

2.2 Video management MOBOTIX HUB 
MOBOTIX has stood for high-end video systems since 1999. The revolutionary decentralized 
edge approach of the first MOBOTIX IP camera has already changed the industry from the 
ground up. In the tradition of this engineering art, we develop, produce, and program video 
systems and software for groundbreaking complete solutions. 

MOBOTIX video solutions provide businesses and organizations with actionable data that 
improves operational efficiency and safety.  

MOBOTIX HUB is an easy-to-use but powerful software designed with open architecture. This 
means that all MOBOTIX HUB are compatible with more IP cameras, encoders and digital video 
recorders than those of any other VMS manufacturer, giving you the freedom to mix and match. 

Generic events allow you to trigger actions in the MOBOTIX HUB Event Server by sending 
simple commands via the IP network. The MOBOTIX HUB is able to analyse received TCP data 
packets, and automatically trigger predefined alarms, e.g. when a call is triggered in the 
Intercom system. 

2.3 System overview 
The interface and all components are fully IP-based. You only have to connect the Commend 
Intercom system and the MOBOTIX HUB Server to your network as shown in the “Example 
system overview”. 
The MOBOTIX HUB VMS system includes at least two software products, the MOBOTIX HUB 
Server and a MOBOTIX HUB Desk Client. These devices and the Commend Intercom Server 
have to be linked via a conventional LAN network connection. 
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Example system overview 

2.3.1 MOBOTIX HUB Server 
The MOBOTIX HUB Server is an advanced IP video management software (VMS) designed for 
medium and large multi-site installations. It is able to analyse received TCP data packets from 
the Commend Intercom Server.  

2.3.2     MOBOTIX HUB Desk Client 
The MOBOTIX HUB Desk Client has an adaptable user interface that can be optimised for 
individual operators’ tasks and adjusted according to specific skills and authority levels. 
Advanced investigation software combined with an easy-to-navigate video timeline enables 
fast and accurate examination of incidents. 

Key features 

� Alarm manager: Single-point alarm function provides a clear and consolidated overview of 
security and system-related alarms and gives instant access to cameras for immediate 
detection of incidents. 

� Map function: The multi-layered map function provides instant situational awareness and 
allows users to interactively access and control cameras, devices and other integrated 
systems. 

� Overlay buttons: Intuitively control cameras, camera-integrated devices and other connected 
systems directly from the camera view, streamlining workflows and improving operator 
efficiency. 

2.3.3 Intercom system  
The Intercom system includes at least an Intercom Server and one control desk station. In most 
cases the control desk or the Intercom station is used in combination with a MOBOTIX HUB 
Desk Client (see also ”System overview” on page 5).  

If a call is triggered by one of the Intercom stations, the video stream from the appropriate IP 
camera is shown on the appropriate monitor, which is logically assigned to a control desk 
station. Commend’s entire selection of camera-equipped call stations and add-on camera 
modules integrate smoothly with the MOBOTIX HUB video management software (VMS). 



MOBOTIX HUB            

8 2.0/0219  

2.4 System requirements 
To use a Commend Intercom system in combination with a MOBOTIX HUB Server, the 
following hard and software is required: 

Commend: 

� Intercom Server: GE 800, GE 300, IS 300, VirtuoSIS 
� Feature licence: Lx-PRO3U 
� Intercom Server software: min. PRO 800 3.1 
� Configuration software: min. CCT 800 3.1 
� Interface licence: L-IF-MILEST* 
� IP interface card G8-IF/G3-IF/SIS-IF or GEP 

MOBOTIX: 

� MOBOTIX HUB version**:  
L5, L4, L3 

� MOBOTIX HUB Desk Client 

Network: 

� LAN / WAN Network 

* To run a MOBOTIX HUB interface, no additional ICX licence is required. 
** MOBOTIX HUB version must provide generic events via TCP/IP (check MOBOTIX HUB Product 
Comparison Chart). 
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System setup 

3. System setup 
In the following sections, the required configuration is described. After successful installation 
it is necessary to configure the network connection between Commend Intercom system and 
MOBOTIX HUB Server. Both systems have to be in the same network range. 

3.1         MOBOTIX HUB 

3.1.1 Installation 
For installation of the MOBOTIX HUB Server and Desk Client, follow the instructions in the 
MOBOTIX HUB Administrator's Manual. 

Download link: https://www.mobotix.com/en/manuals 

3.1.2 Network configuration 
To establish the network connection between the MOBOTIX HUB Server and VMS Video Client, 
follow the instructions in the respective documentation. Use the Generic Events tab (see 
“Configure a generic event” on page 10) to configure the necessary port for generic events. 

� It is recommended to use “17800” as the generic event port. 

3.2 Commend Intercom Server 

3.2.1 Installation 
Follow the steps below to install the Commend Intercom Server: 

1. Start the Commend Intercom Server configuration software CCT 800. 
2. Establish a connection to the Intercom Server. 

� Default IP address: 10.10.1.1 
� Subnet mask: 255.255.0.0 

NOTE:  
For detailed information, see manual “Intercom Server Configuration”. 

3.2.2 Network configuration - Commend Intercom Server Setup 
Follow the steps below to configure the Commend Intercom Server: 

1. Start the Commend Intercom Server configuration software CCT 800 and establish a 
connection to the Intercom Server.  

2. Select the interface for the TCP/IP connection to the MOBOTIX HUB Server. It is possible to 
use the interface on the GEP card or the interface on an interface card G3/G8/SIS-IF. 

3.2.3 IP card definition  
To connect the Intercom system to the network, it is necessary to define appropriate IP 
addresses for the GEP card and NET card. If you want to use an interface card for the connection 
to the MOBOTIX HUB Server it is also necessary to define an IP address for the IF card. 
 

 

 

https://www.mobotix.com/en/manuals
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Follow the steps below to define the appropriate IP addresses for the GEP, NET and IF card: 

1. Go to: Project > IP - Settings > tab Common 
2. Define Card IP address and Subnet mask for the GEP card, NET card and IF card  

 

CCT 800: Define IP addresses 

3. Go to: Intercom Server > Send  
The settings become active when the configuration is sent to the Intercom Server. 

3.2.4 Software licence activation 
It is required to assign the licence L-IF-MILEST to the respective interface on the GEP card or 
on the respective interface card SIS/G3/G8-IF. 

The licensing procedure is described in the manual “Intercom Server Configuration”.  

3.3 Interface configuration 

3.3.1 Define an interface at the Intercom Server 
To connect to the MOBOTIX HUB Server, it is necessary to define an interface at the Commend 
Intercom Server.  

Follow the steps below to establish the interface connection: 

1. Go to: Project > Interfaces > Data interfaces > tab TCP/IP.  

 

2. Select the interface on the GEP card or on the IF card for the connection to the MOBOTIX 
HUB Server.  
� Call number: It is recommended to use the default call number of the selected interface.  
� Description: Use this field for an interface description as shown in the screenshot. � 
Type of connection: Select “MOBOTIX HUB”. 
� Local port: The MOBOTIX HUB Interface does not need a local port setting. 
� Remote IP address: Set the IP address of the MOBOTIX HUB Server.  
� Remote port: Configure the port number that is set in the MOBOTIX HUB Server (default: 

17800). 
� Idle interval: Connection state is checked within this time interval (recommended: 1 

minute). 
� Idle response time: Communication timeout (recommended: 2 seconds). 
� Length ICX - messages: Configure the length of the ICX messages to “Always long”. 

CCT 800: Define data interface 
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System setup 

» The settings become active when the configuration is sent to the Intercom Server. 

NOTE: Define a control desk - Assign an ICX interface 
For the data connection to the MOBOTIX HUB interface it is recommended to define a control 

desk and assign an ICX interface. 

3.3.2 Define a control desk function  
Follow the steps below to define a control desk function: 

1. Go to: Project > Subscriber > Control Desks > tab Buzzer 
2. Right-click on a subscriber with feature level D 
3. Click on Add control desk function. The subscriber gets control desk privileges. 

 
CCT 800: Add control desk function 

4. Go to Project > Subscriber > Control Desks > tab IP/RS232 - ICX  
5. In the drop-down list ICX 1 connection, select the previously configured “MOBOTIX HUB 

Interface”. 

 
CCT 800: Select MOBOTIX HUB Interface connection 

6. Send the configuration to the Intercom Server. 

» The control desk generates all corresponding ICX messages within the Intercom system 
and forwards it to the MOBOTIX HUB server via the configured interface connection. 

 
4. Generic events 

Generic events allow triggering actions in the MOBOTIX HUB Server by receiving simple ICX-
based strings from the Commend Intercom Server. The MOBOTIX HUB Server is able to 
analyse received TCP data packets and trigger predefined alarms. The ICX strings and the 
appropriate alarms are defined as generic events. 
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Illustration of TCP data transmissions 

4.1 Configuration 

4.1.1 Configure a generic event 
Follow these steps to define a generic event on the MOBOTIX HUB Server: 

1. Open the MOBOTIX HUB Management Client. 
2. Go to: Tools > Options.... 
3. Open the tab Generic Events. 
4. Enter the port number of the MOBOTIX HUB Server in the field Port (default: 17800). 
5. Enter the IP address of the GEP card, NET card and IF card in the list Allowed external IPv4 

addresses (see “Network configuration - Commend Intercom Server Setup” on page 7).  

 
MOBOTIX HUB Management Client: Generic Events tab 

6. Click on OK. 
7. Go to: Rules and Events > Generic Events 8. Right-click on Generic Events 
9. Select Add new.... 
10. In the field Name, enter the event name. 
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11. Click on OK. 
12. In the field Expression, define the triggering ICX messages.  

 
MOBOTIX HUB Management Client: Generic Events Properties 

Message format: 

Every configured ICX message has to be translated into the following message format: 

� TA_TY_PARAM1_PARAM2 
� TA: TASK (2 digits) 
� TY: TYPE (2 digits) 
� PARAM1: (8 digits)* 
� PARAM2: (8 digits)* 

*leading empty digits filled with F 

Example: 

Message example of a conversation from Intercom station 105 to 110: 
62_12_FFFFF105_FFFFF110 

Conditions: 

It is possible to use operators such as “(“ “)“, “AND“ or “OR“ to combine and link several ICX 
messages for events. 

Expression type: 

Choose an expression type: 
� Search: Is positive if the received TCP string contains the event message expression.  
� Match: Is positive if the received TCP string is exactly the same as the event message 

expression. 

For detailed information about ICX messages, see manual “ICX Protocol”. 
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4.1.2 Add alarms to a generic event 

NOTE 
Alarms can be displayed in the alarm dialogue on the Desk Client. The configuration 

has to be done in the MOBOTIX HUB Management Client. 

Follow the steps below to add alarms to a generic event.  

1. Go to: Alarms > Alarm Definitions 
2. Right-click on Alarm Definitions. 
3. Select Add New.... 
4. Configure the Alarm Definitions (Name, Triggering event, Events triggered, Sources). When 

an event is triggered via ICX message, the alarm is shown in the VMS Video Client.   

 

MOBOTIX HUB Management Client: Alarm Definitions Properties 

 

MOBOTIX HUB Management Client: Select Sources 

WS camera integration 
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5. WS camera integration 

NOTE: Assign cameras and maps 
In the Alarm Definitions dialogue, it is also possible to assign cameras and maps to a generic 

event. When the event is triggered, the associated camera or map is shown in the Desk Client. 

MOBOTIX HUB comes with full support of Commend cameras and camera-equipped Intercom 
stations. The network configuration of the WS cameras has to be carried out via the Commend 
configuration software IP Station Config. 

5.1 Configuration 
The following section describes how to add a WS camera. For adding an Intercom station 
equipped with an Axis camera, use the auto discovery feature to detect and configure it. 

5.1.1 Add a WS camera to an MOBOTIX HUB Server 
Follow these steps to add a WS camera to a MOBOTIX HUB Server: 

1. Open the MOBOTIX HUB Management Client. 
2. Go to: Servers > Recording Servers 
3. Right-click on the recording server. 
4. Select Add Hardware. 

 

MOBOTIX HUB Management Client: Add Hardware 

5. Select Manual. 
6. Click on Next. 
7. Activate the Include checkbox. 
8. Enter the User Name and Password of the WS camera. 
9. Select Universal > Universal 1 channel driver. 
10. Click on Next. 
11. Enter the IP Address and Port of the WS camera. 
12. (Optional) Click on Add to add more cameras. 
13. Click on Next. 
14. Click on Next. 
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WS camera integration 

15. Click on Next. 
16. Click on Next. 
17. Select a group. 
18. Click on Finish to show the new device in the system overview. 
19. Go to: Servers > Recording Servers 
20. Click on the WS camera. 
21. In the Properties window, click on the Settings tab. 
22. Set video properties as shown in the screenshot:   

 

MOBOTIX HUB Management Client: Properties  

23. Go to: File > Save to save any changes. 

 
6. Desk Client 

The MOBOTIX HUB Desk Client provides access to surveillance systems. The MOBOTIX HUB 
Desk Client must be installed locally on the computer. In the MOBOTIX HUB Desk Client 
window, it is possible to view live video in the Live tab of the MOBOTIX HUB Desk Client and 
recorded video in the Playback tab. When the Live tab is selected, the MOBOTIX HUB Desk 
Client connects to the surveillance system server and displays live video from cameras in the 
selected view. 

If the computer has more than one physical display attached, it is possible to send individual 
views to separate windows and watch more than one view at a time. 

6.1 Alarm manager 
The Alarm manager tab is either displayed or hidden depending on the settings defined by 
your surveillance system setup.  
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6.1.1 The alarm list 
The alarm list displays incoming alarms by default, with the most recent alarms at the top of 
the list. Alarms or events that have video associated with them are listed with an icon. To 
preview a still image from the time of the alarm or event, place the mouse over the icon. To 
view recorded video from the camera associated with the alarm or event, select the alarm or 
event in the list to display it in the Alarm preview.  

6.1.2 Alarms on maps 
If your alarm handling view contains one or more map positions, you can view alarms on the 
maps too. Maps display alarms based on the geographical location of the camera, server or 
other device triggering the alarms, which allows you to instantly see where the alarm originates 
from. You can right-click and acknowledge, disable, or suppress the alarm directly on the map.  

Camera elements display video in thumbnail format when you move your mouse over it. When 
used together with alarms, the graphical elements on the maps display white circles around 
them if alarms occur.  

 
7. Technical support 

For more information about our products and services visit: 

 www.commend.com 

 

For downloads of MOBOTIX HUB software visit: 

 

MOBOTIX Software Download 

 
For further infos about the MBOTIX HUB and Partner Integration check the MOBOTIX 
Community: 

 

MOBOTIX Community - Section HUB 
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