Downgrading D24M to / Back to plain FTP

Initial problem: Camera has been updated from →

  • → FTP upload working
  • → FTP upload not working any more (“FTP transmission timed out 32”)

D24M — FTPS → ftp-server → timeout
Filezilla — FTPS → ftp-server → timeout
Filezilla — FTP → ftp-server → OK

Rootcause: Possibly misconfigured FTP server, which can not easily be changed (if it could be changed, we certainly would do it)

My workaround: Downgrade to a firmware version prior to MX-V4.4.2.69 where FTPS support has been added:

Support for FTPS (FTP over TLS)
When transferring data via FTP profiles, FTP servers can now be used which support the more secure FTPS protocol (FTP via TLS). Once the connection is established, the camera automatically logs the protocol used with the FTP server. TLS 1.0 to TLS 1.2 are supported and the most recent version, TLS 1.2, is the preferred version.

My hopes are that the FTP upload will then work again.

When trying to do so, I receive the following in the status window:

Update started 2021-10-25 12:41:37 CEST 
Switched into admin mode.
Released critical resources.
Fatal: Signatures failed. Aborting.

How can I solve this and downgrade to

Set camera time to 2017-12-01. You should be able to downgrade then.

1 Like

Thanks, that worked! :slight_smile:

Unfortunately, I picked the wrong release and had to go through the process twice.
Finally MX-V4.4.2.34 solved my problem, I’m back on plain FTP instead of FTPS and the upload is working again.

1 Like