Error update firmware

Hi community.

I’m trying to update a Q25 to the latest firmware and I always get this error:

"- preparing system for upload

  • starting upload
    Update started Mon Nov 20 11:56:00 CET 2023
    Digital signatures successfully verified.
    Upload part #0: CHECK_SCRIPT
    Checking camera type… type 2, ok.
    Upload part #1: BOOTLOADER
    Upload part #2: FPGA_BLA7
    Failed to write FPGA_BLA7 to flash.
    Upload part #3: FPGA_BL
    Upload part #4: SCRIPT_CLEAN_SYSTEM
    Erasing system UBI volumes…
    VOLUME 10
    VOLUME 11
    VOLUME 12
    VOLUME 13
    VOLUME 14
    Upload part #5: KERNEL
    Failed to write KERNEL to flash.
    Upload part #6: FPGA
    Failed to write FPGA to flash.
    Upload part #7: XPACK
    Failed to write XPACK to flash.
    Flash has CRC error at XPACK.
    Upload part #8: RAMDISK
    Failed to write RAMDISK to flash.
    Upload part #9: DEFAULTCONFIG
    Failed to write DEFAULTCONFIG to flash.
    Upload part #10: PATCH
    UBI mount rw failed: REBOOT IS NECESSARY!"

The current firware is MX-V4.4.2.73.
I tried to update the next version and the last version, with the same error…
Do you know what this error could be due to?


First, make sure that the camera’s date and time are up to date.
If you are sure the date and time are current

You can try the updates of the camera step by step.

MX-System Release
MX-System Release
MX-System Release
MX-System Release
MX-System Release

Hi Deniz.

The camera´s date and time are up to date.
date time

I tried with the fw and and get this error.

System Upload Log Window

  • preparing system for upload - starting upload Update started Tue Nov 21 15:55:31 CET 2023 Fatal: Signatures failed. Aborting.

I read in another post that for this error the time had to be changed to one year from the date of the fw.
I change the date and the original error “Failed to write KERNEL to flash” appears again

I am updating around 60 cameras and so far only one has failed…

Any more suggestions?

Can you store configuration on the camera? I mean if changes in settings are kept after reboot. I had cameras where “flash” was in some kind of “read only” state. We scraped those cameras.

Hi Andrius.

Yes, the configuration saves correctly.
In fact, in this revision I changed the nfs path and after the reboot it correctly saved the changes.

What i would try:

  • Disable ntp
  • Set clock to 2017-12-30
  • Format the sd card
  • Reset config
  • Upload MX_system_4_4305.mpl

if this would work, next step would be set to 2019-07-01 and try with MX_system_4_7221.mpl after that latest. If not, try and contact support with camera report file. Maybe they will be able to help.

Hi Andrius

I don´t find 4_4305.mpl.
In this page
From version 4.4.2.xxxx jumps to version 4.7.2.xxxx

Anyway, i tried your steps with version but the error persits.
I will try contact support.