Problem accessing M24M via browser (i did set a wrong port)

I have a M24M.Sec-Night camera.
I made an error while configuring the Server Web page.
I did probably enter a wrong port in HTTPS and disabled HTTP.
Now I cannot access the camera in any way; i tried port 443, the port I entered, port 554 (that I see is open on the camera) but I cannot access it.
I tried to reset with the R button, and I can ping the camera but cannot access via browser.
Is there any way to hard reset the camera to factory defaults, and then enter my parameters?
Paolo Gramigna from Italy

For https you need to specify, by entering beffore ip that it uses https, and make sure it’s not the browser that shows error of bad(self-signed) certificate which could be bypasessed.

You could could try MxMC it usualy detects port that is actualy set in camera.

If that fails, disconnecting camera power, and pressing button near red led and keeping it pressed while camera is booting until it flashes was my go to method for older cameras.