[Solved] IP notify text messages probelms

Hello community
I wanted to support a project with multiple cameras and a single unit of meteo station. So i hoped that data from the station would be sent to all cams through ip notify text messages which is described to many topics in here like Getting Started with IP Notify Messages or How to send a text message to display information on a remote camera.
Then I tried to apply the first example of the topic in order to demonstrate to the client the local ambient temp from one cam(m15) to another (d14). I am following exactly the instructional and I get a message in the listener cam like -no stringline text found-. Could someone test the example again and tell me if he gets any results? Is it possible to have to do with the different versions of the cams or that has been disable somehow with the latest firmware?

`(SEN.TEX.CELSIUS) is the temperature reading of an EXTIO. So, unless you are using one of those with the M15, you may not get a reading of the temperature for the M15. For ambient and internal temperatures of the M15(this model has both), you can use this: (SEN.TIN.CELSIUS) and $(SEN.TOU.CELSIUS) to get those temperatures.

I tested this string: “Temperature: $(SEN.TIN.CELSIUS)” with an M15(sending) and a D12(receiving). This did work for me. I did not set up a time task though. Hope this helps.

Hello Ben
I am using the SEN.TOU.CELSIUS. You mean that you have tested the IPNotify by the Ethernet setting test I suppose and when it was successful you were able to see it through the screen on the D12?
Could we make a skype chat share screen to check your settings. I am pretty sure I am missing something here. I tried several times the settings and although successfully being sent by the sender( i can see the message with the proper temp after the successful test of the IPNotify but does not pass to the listener. My only change is that I have port 9091 in the sender M15 instead of 8000.
Thanks for you kind reply.

Do you also have the sending unit port at 9091?

In order to receive the TCP message, Camera B needs to be listening on the same port Camera A is sending the message to (e.i. port 8000).

I’m sure you know this. But I had to ask.

I hope we can figure this out on this site. That way everyone can hopefully get some useful information from our exchange.

Thanks for your answer. Of course I changed it to 9091. It seems that for some reason I cannot get it to work. It accepts http command normally but not the text messages. I have spend hours trying to figure it out. I have the latest firmware on both came and I worry that might have to tdo with this. I gave up and send mobotix support a ticket

I’m sorry I was not really able to help you. I can certainly understand spending hours and hours on an issue. I’m not an expert on Mobotix. I’m just a personal owner of a few cameras for the last 8 years.

A non-expert thought:
Have you tried sending from the d14 unit to the m15 to see if that worked?

Yeap I did try this also. Second thing to try :). No luck at all

Here are screenshots of my IP Notify setup for temperature. I use “Test Network Configuration” to test this.

1 Like

Thank you very much indeed.
It seems that although your screen shots were like my settings teh ipnotify does not work…
Thank you very much indeed.

1 Like

Hello Ben
Actually I found my mistake with the help of the Mobotix Support.
So in the help file when you create an IP Notify you are instructed to do the flowing:

" Enter the IP address(es) and the port(s) (separated by a colon) to which the camera is supposed to send the network message in the Destination Address field."

So I interpreted this as the IP address of the destination camera and its web server IP address.

This is a mistake as you need the destination address and a colon followed by the port at which the camera should listen(similar to the message events setting on IP Receive Value and not the webserver port of the destination cam.

If you are not messing with the IP of the cameras and you use the default settings I suppose it works somehow, but if you have changed the ports as I did then teh instructions might be misleading…

So I hope someone else could spare the grief.

1 Like

For the destination address you will always need to specify the port even for default port 80. Another thing that is often overlooked is >Admin >Test Current Network Configurations. This menu is the main testing tool for all of the transfer profiles i.e. email, ftp, ipnotify. Remember that when you first go to this menu to allow the pop-up so that you get the Network Test Log window. With the Network Test Log you can test a transfer profile and see exactly what the result is from the test.